Opened 22 months ago

Closed 22 months ago

Last modified 22 months ago

#6050 closed defect (fixed)

Fix string formatting in typemaps_perl.i

Reported by: volter Owned by: Ari Jolma
Priority: normal Milestone:
Component: PerlBindings Version: unspecified
Severity: normal Keywords:
Cc:

Description

See attachment!

Attachments (1)

gdal-2.0.0-swig-perl-format.patch (460 bytes) - added by volter 22 months ago.

Download all attachments as: .zip

Change History (4)

Changed 22 months ago by volter

comment:1 Changed 22 months ago by Even Rouault

Component: defaultPerlBindings
Owner: changed from warmerdam to Ari Jolma

comment:2 Changed 22 months ago by Ari Jolma

Resolution: fixed
Status: newclosed

Fixed in r29582 (branch 2.0) and r29583 (trunk).

comment:3 Changed 22 months ago by Ari Jolma

By the way, I'm not happy with croak in typemaps. I'd like it to be confess as in elsewhere now in the bindings. This is because the cause for the errors within GDAL are often difficult to locate in top level Perl code.

Note: See TracTickets for help on using tickets.