#6005 closed defect (fixed)

/vsizip/ caches file content a bit too agressively

Reported by: Even Rouault Owned by: warmerdam
Priority: normal Milestone: 2.0.1
Component: default Version: unspecified
Severity: normal Keywords:
Cc:

Description

/vsizip/ (actually the abstract archive handler) caches the file listing when opening a zip. The problem is that if the zip is later changed, the file listing is not refreshed.

Change History (2)

comment:1 Changed 22 months ago by Even Rouault

trunk r29387, branches/2.0 r29388 (post RC2) "/vsizip/: avoid returning the previous file list of an already opened .zip if it has changed afterwards (#6005)"

comment:2 Changed 22 months ago by Even Rouault

Milestone: 2.0.1
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.