Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#5297 closed enhancement (fixed)

USRP/ARSP driver don't read theTRANSH01.THF

Reported by: lhomme Owned by: warmerdam
Priority: normal Milestone: 1.11.0
Component: GDAL_Raster Version: 1.10.1
Severity: normal Keywords: asrp usrp
Cc:

Description

The ASRP/USRP driver don't read the TRANSH01.THF.

Attachments (1)

srpdataset.cpp (43.8 KB) - added by lhomme 4 years ago.
proposal

Download all attachments as: .zip

Change History (3)

Changed 4 years ago by lhomme

Attachment: srpdataset.cpp added

proposal

comment:1 Changed 4 years ago by Even Rouault

Milestone: 1.10.22.0
Resolution: fixed
Status: newclosed
Type: defectenhancement

I've integrated your patch with a few minor changes (one mem leak fix, recognize gen files in same directory as THF based on 6 first characters of the name, disable recognizing of .gen files to avoid "duplicate" because we already recognize .img files), doc and regression test additions.

r26635 "SRP: read TRANSH01.THF file to establish subdatasets (patch by Xavier Lhomme, #5297)"

comment:2 Changed 3 years ago by Even Rouault

Milestone: 2.01.11.0
Note: See TracTickets for help on using tickets.