Opened 3 years ago

Closed 3 years ago

#5262 closed defect (fixed)

ECW_CLEVER mode doesn't work properly when nPixelSpace != sizeof eBufDataType

Reported by: Even Rouault Owned by: Even Rouault
Priority: normal Milestone: 1.10.2
Component: GDAL_Raster Version: 1.10.0
Severity: normal Keywords: ecw jpeg2000
Cc:

Description

Reported as http://lists.osgeo.org/pipermail/gdal-dev/2013-October/037218.html

The issue is that when writing from the internal cached buffer to the user provided buffer we use the size of the buffer data type as the pixel stride, instead of the nPixelSpace value provided by the user.

Workaround : set ECW_CLEVER=NO as environmenet variable/configuration option.

Change History (1)

comment:1 Changed 3 years ago by Even Rouault

Resolution: fixed
Status: newclosed

Fixed in trunk (r26518) and branches/1.10 (r26519)

Note: See TracTickets for help on using tickets.