Opened 6 years ago

Closed 5 years ago

#5128 closed defect (invalid)

Console redirection fails

Reported by: jolly47roger Owned by: warmerdam
Priority: normal Milestone:
Component: default Version: 1.10.0
Severity: normal Keywords: Console redirection fails
Cc:

Description

I raised a support ticket #5073. I thought it had been resolved but it has not. I have, however, got closer to the problem.

My program invokes GDALINFO to extract the projection and other information from a GEOTIF. I redirect the console so that the program can analyse and act on the information returned.

This works correctly with GDAL 110-1600-x64 core.

But if I install the ECW extension for this version then console redirection stops. If I uninstall the ECW extension it works correctly again. The MrSid? extension works OK

I am running windows 7 64 bit, but this also happens with XP 32bit

Change History (4)

comment:1 Changed 6 years ago by 45136

Confirmed here. Renaming the driver bin\gdal\plugins\gdal_ECW_JP2ECW.dll activates the output again.

comment:2 Changed 6 years ago by 45136

Version: unspecified1.10.0

comment:3 Changed 6 years ago by Even Rouault

http://lists.osgeo.org/pipermail/gdal-dev/2013-September/037079.html

Even Rouault even.rouault at mines-paris.org
Tue Sep 17 16:35:57 PDT 2013

    Previous message: [gdal-dev] Gdalinfo does not print into file on Windows
    Next message: [gdal-dev] Gdalinfo does not print into file on Windows
    Messages sorted by: [ date ] [ thread ] [ subject ] [ author ]

Selon Andre Joost <andre+joost at nurfuerspam.de>:

> Am 17.09.2013 17:02, schrieb Even Rouault:
> > Hi Jukka,
> >
> > This reminds me a lot the following ticket :
> > http://trac.osgeo.org/gdal/ticket/5128
> >
> > Could you confirm that the analysis done (i.e. the cause of the problem
> would be
> > the ECW plugin) also applies to you ? I'm not sure if you must completely
> > uninstall (or rename) the gdal_ECW.dll, or if specifying GDAL_SKIP=ECW as
> > environmenet variable is sufficient
>
> Confirmed here. Removing or renaming the gdal_ECW_JP2ECW.dll in \bin
> solves the problem. The file investigated was a .tif, so the ecw driver
> was not used at all. Tested on gisinternals sdk version 1-10-0 from
> 07.09.2013.

Hum, this is an interesting (=annoying) issue. Here's the result of my tests
(only on 32 bit builds) :
- release-1600-gdal-1-10-mapserver-6-2 : bad
- release-1600-gdal-1-9-1-mapserver-6-0-3 : bad
- release-1400-gdal-mapserver (latest dev version): bad
- release-1500-gdal-mapserver (latest dev version): bad
- release-1400-gdal-1-8-1-mapserver-6-0-1 : bad
- release-1310-gdal-mapserver (latest dev version): ... good ...
- release-1310-gdal-1-8-1-mapserver-6-0-1 : good

So my conclusion is that it does not depend on the GDAL version, but it does
depend on the MSVC compiler. And apparently only MSVC 1310 pleases the ECW SDK.
The issue must be a bad interaction between the old ECW SDK 3.3 code and MSVC >=
1400.

I've reported it as https://github.com/gisinternals/buildsystem/issues/36 to
Tamas as this is more a packaging issue, but I'm not sure what can be done in
practice. Unless someone is willing to debug that. Perhaps the issue has gone
with newer versions of the ECW SDK.

comment:4 Changed 5 years ago by Even Rouault

Milestone: 1.10.1
Resolution: invalid
Status: newclosed

Closing this ticket. This is a SDK 3.3 bug. Nothing we can probably do about that

Note: See TracTickets for help on using tickets.