Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#5114 closed defect (fixed)

netcdf driver incorrectly calculates geotransform

Reported by: etourigny Owned by: etourigny
Priority: normal Milestone: 1.10.1
Component: GDAL_Raster Version: unspecified
Severity: normal Keywords: netcdf, geotransform
Cc:

Description

In some specific cases the geotransform detection routine in SetProjectionFromVar?() fails to detect geotransform because the spacing calculation (begin,middle,last) fails due to a rounding error. Fix is to increase the resolution of the difference checking (from diff*100 to diff*1000).

Change History (4)

comment:1 Changed 4 years ago by etourigny

actually, fix is to increase resolution from diff*10000 to diff*100000

fixed in trunk (r 26075) and added test (r26074)

comment:2 Changed 4 years ago by etourigny

Resolution: fixed
Status: newclosed

fixed in 1.10 (r26077)

comment:3 Changed 4 years ago by etourigny

see related bug #5118

comment:4 Changed 4 years ago by etourigny

fixed regression in trunk (r26108) and 1.10 (r26110)

Note: See TracTickets for help on using tickets.