Opened 3 years ago

Closed 6 months ago

#4578 closed defect (wontfix)

GDAL/OGR filegdb layer visibility

Reported by: glafleur Owned by: warmerdam
Priority: normal Milestone:
Component: default Version: unspecified
Severity: normal Keywords: filegdb
Cc: rcoup

Description

OGR is unable to see some of the layers in my filegdb. I have attached to this ticket a file geodatabase with 3 feature classes in it. OGR can see one of them, the one named 'reg'.

The one that it can see was copied from a shape file into the geodatabase and has a geometry column called SHAPE.

The other two were copied out of oracle sde and have columns called 'GEOMETRY'.

to reproduce run ogrinfo on the attached filegdb.

Attachments (1)

arc10gdb2.zip (713.9 KB) - added by glafleur 3 years ago.

Download all attachments as: .zip

Change History (7)

Changed 3 years ago by glafleur

comment:1 Changed 3 years ago by rouault

  • Cc rcoup added

comment:2 Changed 3 years ago by rouault

$ ogrinfo arc10geodb.gdb --debug on
FGDB: Error opening \bei. Skipping it (Invalid function arguments.)
FGDB: Error opening \VEG_t. Skipping it (Invalid function arguments.)
FGDB: Error opening \WATBOD_t. Skipping it (Invalid function arguments.)
FGDB: Error opening \bei_CopyFeatures1. Skipping it (Invalid function arguments.)
OGR: OGROpen(arc10geodb.gdb/0xfbbf50) succeeded as FileGDB.
INFO: Open of `arc10geodb.gdb'
      using driver `FileGDB' successful.
OGR: GetLayerCount() = 1

1: reg (Multi Polygon)

The "Invalid function arguments" seems to be a deficiency of the FileGDB SDK itself, mentionned in http://trac.osgeo.org/gdal/ticket/4224 and which points to http://forums.arcgis.com/threads/36745-File-Geodatabase-API-1.1-now-available?p=127473&viewfull=1#post127473

comment:3 Changed 3 years ago by peifer

Just to confirm: I opened the attached file geodatabase in ArcCatalog? and redefined the CRS for the invisible layers: Select pre-defined Coordinate System > Projected Coordinate Systems > National Grids > Canada > NAD 1983 BC Environment Albers. Now all feature classes are visible:

$ ogrinfo arc10geodb.gdb/
INFO: Open of `arc10geodb.gdb/'
      using driver `FileGDB' successful.
1: bei (Multi Polygon)
2: WATBOD_t (Multi Polygon)
3: reg (Multi Polygon)

The FileGDB SDK doesn't support "custom coordinate systems", whatever ESRI's definition of "custom" is.

comment:4 Changed 3 years ago by maphew

  • Keywords filegdb added

Just got bit by this myself. It took days to find the cause. Thanks for recording the issue, and please vote for fixing it upstream at http://ideas.arcgis.com/ideaView?id=087E00000004DpoIAE

comment:5 Changed 3 years ago by msmitherdc

I had this problem with layers in State Plane Oregon North Zone (3601) US_Foot. However, testing with the FileGDB API 1.2 on OS X and it reported the layers in that projection without a problem and was able to read the layers just fine.

comment:6 Changed 6 months ago by jratike80

  • Resolution set to wontfix
  • Status changed from new to closed

I understood that the issue was caused by FileGDB SDK and not by GDAL. Closing as wontfix.

Note: See TracTickets for help on using tickets.