Opened 9 years ago

Closed 9 years ago

#3551 closed defect (fixed)

NITFReadImageLine() and NITFWriteImageLine() segfault when nCols < nBlockWidth

Reported by: Even Rouault Owned by: Even Rouault
Priority: normal Milestone: 1.7.3
Component: GDAL_Raster Version: unspecified
Severity: normal Keywords: nitf
Cc: warmerdam, Gary.Smart@…

Description

Reported by Gary Smart as http://lists.osgeo.org/pipermail/gdal-dev/2010-April/024415.html and http://lists.osgeo.org/pipermail/gdal-dev/2010-April/024414.html.

I have confirmed it with the sample provided in the mail, except that the header was incorrect because of 6 extra bytes '000404' at offset 360 (I suspect the sample was hand edited somehow as neither trunk, GDAL 1.7, GDAL 1.6 or nitro-nitf were able to open the original file)

Attachments (1)

farn_modified_by_EvenR.044.ntf (192.9 KB) - added by Even Rouault 9 years ago.

Download all attachments as: .zip

Change History (5)

Changed 9 years ago by Even Rouault

comment:1 Changed 9 years ago by Even Rouault

Status: newassigned

Fixed in trunk (r19547) and in branches/1.7 (r19549). Tested in r19548.

(Should be targeted 1.7.3 when milestone 1.7.3 is created)

comment:2 Changed 9 years ago by warmerdam

Milestone: 1.7.3

comment:3 Changed 9 years ago by warmerdam

Component: defaultGDAL_Raster

comment:4 Changed 9 years ago by Even Rouault

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.