Ticket #3034 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

gdaladdo not producing correct overviews for greyscale+alpha image

Reported by: esok Owned by: warmerdam
Priority: normal Milestone:
Component: Utilities Version: 1.6.1
Severity: normal Keywords:
Cc:

Description

In gdal 1.6.1, gdaladdo is not producing the correct overviews for an image I'm working on. It works correctly with gdal 1.5.4. The image is very large and can be found at  http://www.map.nasa.gov/esok/200906191445-goes12-fulldisk-ir4.tiff in case it cannot be attached to this ticket. I then try to run:

gdaladdo -r average 200906191445-goes12-fulldisk-ir4.tiff 2 4 8 16

Symptoms: The image appears blank at some resolutions, notably 512x512 and 256x256, where the greyscale depth goes from 8 to 1. gdal 1.5.4 works correctly and the greyscale depth remains at 8 at the smaller sizes. I used ImageMagick?'s "identify -verbose" utility to determine bit depths for the overview images.

Change History

Changed 5 years ago by rouault

  • status changed from new to closed
  • resolution set to duplicate

Duplicate of #3033

Note: See TracTickets for help on using tickets.