Opened 9 years ago

Closed 8 years ago

#2305 closed defect (fixed)

gdalwarp fails with many global projections

Reported by: jluis Owned by: warmerdam
Priority: normal Milestone: 1.7.0
Component: default Version: svn-trunk
Severity: normal Keywords:
Cc: neteler

Description

Hi, Here are a couple of examples on how gdalwarp fails when projecting a global image

gdalwarp -t_srs +proj=sinu w.tiff w_sino.tiff Creating output file that is 1147P x 572L.

gdalwarp -t_srs +proj=eck4 w.tiff w_eck4.tiff Creating output file that is 1145P x 572L.

gdalwarp -t_srs +proj=vandg w.tiff w_vandg.tiff Creating output file that is 572P x 572L.

Joaquim Luis

Attachments (2)

w.tiff (402.2 KB) - added by jluis 9 years ago.
w_sino.jpg (120.0 KB) - added by neteler 8 years ago.
broken sinusoidal projection result (converted to JPG due to trac file size limit)

Download all attachments as: .zip

Change History (5)

Changed 9 years ago by jluis

Attachment: w.tiff added

comment:1 Changed 8 years ago by neteler

Cc: neteler added

Changed 8 years ago by neteler

Attachment: w_sino.jpg added

broken sinusoidal projection result (converted to JPG due to trac file size limit)

comment:2 Changed 8 years ago by neteler

Version: unspecifiedsvn-trunk

Frank,

e.g., with +proj=sinu the equatorial zone is flipped horizontally. Reproduced with recent trunk.

Markus

comment:3 Changed 8 years ago by Even Rouault

Milestone: 1.7.0
Resolution: fixed
Status: newclosed
  • r18035 /trunk/gdal/ (alg/gdaltransformer.cpp apps/gdalwarp.cpp ogr/ogrct.cpp): gdalwarp: better heuristics to guess output extent when projection from lat/long world extent to other world global projections (sinu, eck4, vandg, EPSG:3785,...); add a CHECK_WITH_INVERT_PROJ configuration option that can be set to TRUE to force OGRProj4CT::TransformEx? to check that the result is correct by checking with the inverse projection. gdalwarp can auto-sets this variable when it detects that some points on the edge of the computed raster cannot be projected
  • r18036 /trunk/autotest/utilities/ (data/w_jpeg.tiff test_gdalwarp.py): Add test for gdalwarp to global projections (#2305)
Note: See TracTickets for help on using tickets.