Opened 12 years ago

Closed 11 years ago

#2256 closed defect (fixed)

Problem Opening ENVI Files

Reported by: jgr007 Owned by: Even Rouault
Priority: normal Milestone: 1.6.0
Component: GDAL_Raster Version: svn-trunk
Severity: normal Keywords: envi
Cc: warmerdam, dmarino

Description

Hi,

I'm using gdal through FWTools to process ENVI files. I'm trying to use both precompiled binary utilites (gdalinfo, etc.) and the python interface. I've encountered problems with FWTools 2.1.0 (I'm not sure which GDAL version Frank is using for 2.1.0) on a Windows XP 32-bit machine.

I tried three different combinations of ENVI files:

1 - myfile, myfile.hdr

2 - myfile.envi.dat, myfile.envi.hdr

3 - myfile.envi, myfile.envi.hdr

gdalinfo and gdal.Open() work fine for all three combinations on my machine (WindowsXP 32-bit) with FWTools 2.0.6.

With FWTools 2.1.0:

  • The first two combinations both work with gdalinfo and gdal.Open()
  • The third one does not seem to work with gdalinfo or gdal.Open()

I posted to FWTools list and Frank confirmed the problem. He said it appears to be specific to the GDAL trunk and asked me to submit a bug report here.

Change History (5)

comment:1 Changed 12 years ago by warmerdam

Cc: warmerdam added
Component: defaultGDAL_Raster
Keywords: envi added
Milestone: 1.6.0
Owner: changed from warmerdam to dmarino
Version: unspecifiedsvn-trunk

Turning over to Donnie who plans to look at it after the 12th.

comment:2 Changed 12 years ago by Even Rouault

Owner: changed from dmarino to Even Rouault

I think I might be responsible for this. Turning the ticket to me.

comment:3 Changed 12 years ago by Even Rouault

Yes, indeed. It was caused by r13740.

Fixed in trunk in r13928

comment:4 Changed 12 years ago by Even Rouault

Cc: dmarino added

comment:5 Changed 11 years ago by Even Rouault

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.