Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#2219 closed defect (fixed)

PCI .AUX with LONG/LAT not working

Reported by: warmerdam Owned by: warmerdam
Priority: normal Milestone: 1.4.5
Component: GDAL_Raster Version: unspecified
Severity: normal Keywords: PAUX
Cc: battisti@…

Description

Hi all,

I am testing the GDAL support for some PCI RAW(+AUX) data. I have no problems loading sample .raw files that use the "SIN" projection (within the corresponding .aux).

On the other hand, GDAL refuses to open a simple file which use "LONG/LAT" projection:

its .aux contains:

RawDefinition: 81 51 1
ChanDefinition-1: 32R 0 4 324 Swapped
MapUnits: LONG/LAT    D000
UpLeftX:    -8.35169600000000E+01
UpLeftY:     4.20982300000000E+01
LoRightX:    -8.24558600000000E+01
LoRightY:     4.14301300000000E+01
ProjParms: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 4

I was able to load the same data file by manually generating a .vrt, but it should work also natively I guess.

PS: I noticed the following lines in the GDAL source (ogr/ogr_srs_pci.cpp:376)

   if( EQUALN( pszProj, "LONG/LAT", 8 ) )
   {
   }

in the case of "LONG/LAT" it does nothing; (I'm not familiar with it); may it be a clue?

Thanks in advance,

-- Andrea Battisti Applied Coherent Technology Corp.

Change History (2)

comment:1 Changed 11 years ago by warmerdam

Resolution: fixed
Status: newclosed

In fact, the .aux file contains:

AuxiliaryTarget: GL20030823_forLE.raw
RawDefinition: 81 51 1
ChanDefinition-1: 32R 0 4 324 Swapped
MapUnits: LONG/LAT    D000
UpLeftX:    -8.35169600000000E+01
UpLeftY:     4.20982300000000E+01
LoRightX:    -8.24558600000000E+01
LoRightY:     4.14301300000000E+01
ProjParms: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 4
METADATA_IMG_1__HISTORY_1: fexport:Exported from 2 on GL20030823_forLE.pix                 15:45 07Feb2008

It turns out the problem is that PCI "fixed" my spelling of AuxilaryTarget? in their software, bug GDAL is still looking for the old spelling. Presumably this was a change in recent versions of Geomatica. I have modified pauxdataset.cpp to accept the old incorrect spelling, and the new correct spelling in trunk (r13765), 1.5 branch (r13766) and 1.4 branch (r13767).

comment:2 Changed 11 years ago by warmerdam

Milestone: 1.5.11.4.5
Note: See TracTickets for help on using tickets.