Opened 12 years ago

Closed 12 years ago

#2191 closed defect (fixed)

ASCII Surfer files (GSAG) read upside down

Reported by: ReedC Owned by: warmerdam
Priority: normal Milestone:
Component: GDAL_Raster Version: svn-trunk
Severity: normal Keywords:
Cc:

Description

Golden Surfer ASCII grid files are being read in upside down. The file format specifies that the file should be defined with data organized in rows starting at Y min and progressing to Y max, but GDAL is reading it assuming that the data is organized from Y max to Y min.

See: http://www.risoe.dk/vea/projects/nimo/WEngHelp/FileFormatofGRD.htm for details on the file format.

Attachments (1)

gsagdataset.cpp (49.9 KB) - added by ReedC 12 years ago.
Fix for this bug and #1616

Download all attachments as: .zip

Change History (4)

comment:1 Changed 12 years ago by Even Rouault

#1616 is a duplicate of this one

Changed 12 years ago by ReedC

Attachment: gsagdataset.cpp added

Fix for this bug and #1616

comment:2 Changed 12 years ago by ReedC

Attached file fixes this driver, as well as solves the final issues in #1616.

comment:3 Changed 12 years ago by ReedC

Resolution: fixed
Status: newclosed

This was corrected in changeset (r13776). See #2224 for full details.

Note: See TracTickets for help on using tickets.