Opened 11 years ago

Closed 11 years ago

#2122 closed defect (fixed)

Attempt to dereference null GDALProgressFunc error in SWIG C#

Reported by: tamas Owned by: tamas
Priority: high Milestone: 1.5.1
Component: CSharpBindings Version: 1.5.0 betas/RCs
Severity: normal Keywords:
Cc:

Description

The method Dataset.BuildOverviews?(string resampling, int[] overviewlist) generates the exception: "Attempt to dereference null GDALProgressFunc".

It seems the recently added callback support have broken some of the existing functions at the SWIG C# interface. In order to make this callback stuff work some typemaps should also be added that I've originally planned to implement later. But as looking into the code since the problem is critical and it seems quite an easy to implement this, I'll commit a fix in the SVN trunk and the branch 5.0

Change History (2)

comment:1 Changed 11 years ago by tamas

Applied the fix in trunk and branch 1-5 (r13458 , r13459)

comment:2 Changed 11 years ago by tamas

Resolution: fixed
Status: newclosed

Closing upon positive user feedback

Note: See TracTickets for help on using tickets.