Opened 13 years ago

Closed 8 years ago

#1303 closed defect (invalid)

TopologyException: no outgoing dirEdge

Reported by: aaran.stent@… Owned by: warmerdam
Priority: highest Milestone:
Component: OGR_SF Version: unspecified
Severity: major Keywords:
Cc:

Description (last modified by Even Rouault)

This problem has been reported on the mailing lists of various projects for some time (years).  The issue appears to be related to a precision error.

The symptom is most prevelant when performing unions of geometries.  There is no discernable pattern to the Geometries that cause the problem as some do not.  In my data (640 features) I found just over 50% of the unions passed.

I have even managed to find this item reported back in May 2005 (but cant find the bug in Bugzilla).  The writer states that the problem is in later version of Geos than mine (and JTS for that matter).
http://geos.refractions.net/pipermail/geos-devel/2005-May/001441.html
This link includes a sample that still fails on my system today.

My system is running Windows XP with...
"POSTGIS="1.0.6" GEOS="2.2.1" PROJ="Rel. 4.4.9, 29 Oct 2004" USE_STATS DBPROC="0.3.0" RELPROC="0.3.0""

Thanks heaps.  Aaran

Change History (1)

comment:1 Changed 8 years ago by Even Rouault

Description: modified (diff)
Resolution: invalid
Status: newclosed

Sound like an issue with ancient GEOS. Closing

Note: See TracTickets for help on using tickets.